I'm on a greenfield project and I tasked myself with setting up a framework for custom BEx variables' logic coding -- some "best of breed" etc etc. After years of being there doing that, I strongly agree that plonking everything in the big case-statement in ZXRSRU01 is bad-bad-bad.
So far, what are the possible alternatives.
1. Old and tried approach of creating a separate program for each variable (naming convention is surely required), then dynamic "perform (form_bexvar) in program (prog_bexvar) using.. changing.." ABAP OOers will frown, but the code is extremely compact, simple and readable, and each BEx variable's code can be independently transported around.. and no problems on the scalability&flexibility front have been detected yet. The only (minor) issue is length restriction on a Bex variable's technical name -- which, actually, hasn't been a problem anywhere so far.
2. The same approach on OO steroids, as per BEx userexits reloaded. In fact, I couldn't get it running in my sandbox BW, as the SAPLink installer gave me a shortdump when I tried to install the code nugget attached to the blog entry. Still, what I got by that point was a number of ABAP classes with a lot of code, which I would understand.. but probably not an average support person taking over the system in a year time. And a couple of transparent tables I would have to create, along with maintenance interfaces.
3. The new BADI introduced with BW 7.3, RSROA_VARIABLES_EXIT_BADI. I swear, I really wanted to try that out, as I do want this greenfield project to be as close to SAP best practices as possible. However, in the documentation department, there are just two blogs machine-translated from German (one and two), which suggest to create a BADI implementing class based on an InfoObject name -- and how that filtering granularity is enough? Another blog on that subject first gives some cut-and-paste from the preceding, then when it comes to the code of the BADI implementing class it suggests... dynamic function module call!
So, do I really have to just resort to #1 of these approaches, or there is something I miss in one of two others? I seriously want to believe in the latter. Thanks!